
Using Macromedia Flash MX

learning interactions

Macromedia Flash MX learning interactions help you create interactive online instructional 
courses that run in Macromedia Flash. Using the Macromedia Flash learning interactions has 
many benefits:

• Anyone with a Macromedia Flash–enabled web browser can use the instructional content 
you create.

• You can customize the interface to meet your needs. Because you are using Macromedia Flash, 
you can create high-quality interfaces that load quickly and look the same on different 
platforms.

• You can easily add interactions to your online course with the Macromedia Flash learning 
interaction components, which provide a simple interface for entering data without writing 
code.

• Each individual Macromedia Flash learning interaction can send tracking information to a 
server-side learning management system (LMS) that complies with the Aviation Industry CBT 
Committee (AICC) protocol. 

• Additionally, the quiz templates track cumulative results from a sequence of interactions and 
can pass them along to the LMS using an enhanced data tracking functionality that conforms 
to either AICC or Shareable Content Object Reference Model (SCORM) standards.

Getting started
To use the Macromedia Flash learning interactions, you need to have Macromedia Flash MX 
installed on your computer. Macromedia Flash MX is available at www.macromedia.com (click 
the Store link).

Your courseware will run on any computer with Flash 6 Player and a Macromedia Flash–enabled 
web browser. 

To track user data from the Macromedia Flash learning interactions, you must have a web server-
side LMS, such as an AICC- or SCORM-compatible system. In addition, users must have 
Internet Explorer 4.0 or Netscape Navigator 4.0 or higher (Windows) or Netscape 4.5 or higher 
(Macintosh). Tracking to a LMS with Learning Interactions will not work with Internet Explorer 
on the Macintosh.
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About Macromedia Flash learning interactions
An interaction is a part of a movie in which the user interacts with the movie to provide a 
response. This interaction may be part of a quiz or other instructional piece. You can use the six 
learning interactions included with Macromedia Flash MX to build interactive courseware:

True or False In this type of interaction, the user responds to a true or false question. 

Multiple Choice The user responds to a multiple-choice question.

Fill in the Blank The user types a response that is checked against matching phrases.

Drag and Drop The user responds to a question by dragging one or more onscreen objects to 
a target.

Hot Spot The user responds by clicking a region (or regions) onscreen.

Hot Object The user responds by clicking an object (or objects) onscreen.

Each of the learning interactions has unique parameters that determine how the interaction will 
appear to the user. The interactions are Macromedia Flash components, which makes them easy 
to implement and configure in a Macromedia Flash document. 

Using Macromedia Flash learning interactions
There are two ways you can include Macromedia Flash MX learning interactions in a document:

• The quiz templates are designed for scenarios in which interaction-based quizzes are required 
and tracking is necessary. The quiz learning interactions are graphically designed to fit into the 
quiz format. The quiz templates contain a mechanism that counts a cumulative score and starts 
and stops the necessary tracking in both the AICC- and SCORM-compliant API. See “Using 
the quiz templates” on page 2.

• The stand-alone interactions are designed for scenarios that require a single interaction, or a 
series of interactions that need to fit into a specific layout within a Macromedia Flash 
document. These are available from the common library and are graphically designed for 
stand-alone use. You can track the results for each individual stand-alone interaction and 
submit it to an AICC-compatible LMS. See “Adding learning interactions to the Timeline” on 
page 7.

To initialize SCORM tracking, you must use a quiz templates.

Using the quiz templates

Each of the quiz templates is set up to let you easily build multipart courses that use the 
Macromedia Flash MX learning interactions. The quiz templates provide built-in navigation to 
advance between interactions. They also include ActionScript that can pass tracking information 
to a web server. 

The quiz templates are fully functional. After creating a document using a quiz template, you can 
immediately test the quiz to see it in action. Included with a quiz are six learning interaction types 
that are stored in movie clips in the library. These movie clips are simply containers for the 
collection of elements that make up each interaction. After you add a learning interaction movie 
clip to the Stage, you must break it apart so you can edit the pieces.
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Three quiz templates are included with the Macromedia Flash learning interactions. Each has 
a different graphic look and feel, but they are otherwise identical. They all contain the 
following elements:

• A welcome page

• One of each of the six learning interaction types

• A Results page

• Navigation elements

• ActionScript to gather AICC and SCORM tracking information

To create a quiz:

1 Create a new file by choosing File > New from Template.

2 In the New Document window, select Quiz in the Category column, then select one of the 
sample quizzes in the Category Items column. 

The quizzes are identical in content but provide different format options. Roll the mouse 
pointer over a template name to preview the format.

Note: Because the document is created from a template, Macromedia Flash will ask you to save a copy of the 
document the first time you choose File > Save. 

3 Click Create. 

The quiz and all its interactions appear on the Stage. The layers of the quiz appear on the 
Timeline.

Setting the quiz parameters

The next step is to set the quiz parameters. These parameters control how the entire quiz is 
presented to users—for example, whether the questions are presented in a random or sequential 
order, LMS tracking information, and whether the Results page is displayed.
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To set quiz parameters:

1 Select the instructions on the left side of the Stage. This selects the Quiz component and allows 
you to set the parameters for the quiz.

Note: These instructions do not appear in the final movie.

2 Open the Component Parameters panel (Window > Component Parameters).

Note: If necessary, resize the Component Parameters panel to make it more legible.

3 Select Randomize if you want the quiz questions to be presented in a random order.

4 In the Questions to Ask text box, specify the number of questions to ask for one presentation 
of the quiz. If you set this to 0, the quiz will always use all the questions you add to the 
document. If you enter a number larger than the number of questions in the quiz, the quiz will 
display only the number of questions that are in the quiz and not duplicate any of them. 

For example, if you have 10 interactions in your quiz, you can pool a lesser number, such as 5 
interactions. This feature is especially helpful used with the randomize feature to create quizzes 
with unexpected questions in an unexpected order. 

5 If you intend to have users log in to take the quiz, and the quiz is not launched through an 
AICC-compliant LMS, specify the Login File URL. The Macromedia Flash movie will redirect 
the user’s browser to this URL if the user has not logged in.

When an AICC-compliant LMS launches a quiz, it includes parameters that are specifically 
looked for by the HTML code that launches the EMBED tag for the Flash movie, and the course 
loads properly. If the launch parameters do not exist, the Login File URL performs the 
automatic redirect. This redirect does not occur in the SCORM template.
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6 In the Activity Name and Activity ID text boxes, enter the activity name and activity ID of 
your LMS, if you are using one. You can leave these blank if you are not using an LMS.

7 Select Show Results Page if you want to present quiz results to the user after they have 
completed the quiz. 

Placing learning interactions in a quiz

Each question in the quiz is considered an interaction. 

When you use a quiz template, you place interactions sequentially between the first and last frame 
of the Interactions layer. You may add or remove frames and keyframes as needed as long as the 
interactions remain sequential and the first and last frames are reserved for the Welcome page and 
Results page.

For example, in a 10-question quiz,

• Frame 1 = Welcome page keyframe

• Frames 2–11 = interactions keyframes

• Frame 12 = Results page keyframe

This would include 12 keyframes across the Interactions layer.

To place learning interactions in a quiz:

1 Select the first frame in the Interactions layer and make any modifications you wish to the text 
of the Welcome page. Make sure you include text to indicate that the user must click the Next 
button to continue. Do not add an interaction to this page.

2 Select each of the learning interactions in the next six frames and do one of the following:

• If you want to use the interaction, follow the instructions under “Configuring a learning 
interaction” on page 6.

• If you do not want to use the interaction, follow the instructions under “Removing a learning 
interaction from the Timeline” on page 9.

3 Select the last frame in the Interactions layer and make any modifications you’d like to make to 
the text of the Results page. Be careful, however, to leave the supplied dynamic text field 
names intact, or the results will not appear. If the Results Page quiz parameter is turned off 
for the quiz, this frame will never be called, but it is still reserved. Do not place interactions 
in this frame.

First frame of the layer

Interactions layer
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Configuring a learning interaction

Included with the quiz is one of each of the six learning interaction types, stored in movie clips in 
the library. These movie clips are simply containers for the collection of elements that make up 
each interaction. When you add a movie clip to the Stage, you must break it apart to freely edit 
the pieces as desired.

To configure a learning interaction:

1 With the entire learning interaction selected, choose Modify > Break Apart. This breaks the 
interaction into individual objects that can be modified.

Note: Be careful to break apart the interaction only once. See “Testing to see if a movie clip is broken apart” on 
page 9.

2 Deselect all the items on the Stage (Control+Shift+A).

3 Select the instructions on the Stage. This selects the learning interaction component.

Note: These instructions do not appear in the final movie.

4 Choose Window > Component Parameters. The Component Parameters panel for the 
learning interaction appears.
6



5 If the Macromedia Flash movie will send tracking information to a server-side LMS, specify a 
name for the interaction in the Interaction ID text box. We recommend that you name each 
interaction uniquely, as specified by your LMS. 

6 In the Question text box, type the text you want to present to the user. This can be a question 
and/or instructions for the user.

7 Configure the learning interaction. See the following sections:

• “Configuring a Drag and Drop Interaction” on page 10

• “Configuring a Fill in the Blank Interaction” on page 11

• “Configuring a Hot Object interaction” on page 13

• “Configuring a Hot Spot interaction” on page 14

• “Configuring a Multiple Choice interaction” on page 15

• “Configuring a True or False interaction” on page 17

8 Click the Options button and enter feedback and Knowledge Track parameters for the 
learning interaction. See “Setting feedback options for an interaction” on page 17, “Setting 
Knowledge Track options for an interaction” on page 19, and “Setting navigation options for 
an interaction” on page 21.

Note: Documents created using a quiz template need to have Knowledge Track set to On and Navigation set to 
Off for each learning interaction.

9 (Optional) Click the Assets button and change the assets for the learning interaction. See 
“Adding, naming, and registering assets” on page 22.

Adding learning interactions to the Timeline

The process of adding a learning interaction to the Timeline is the same whether you’re using a 
quiz template or adding stand-alone interactions to your own Macromedia Flash document.

• If you are using a quiz template, you must add learning interactions sequentially to the 
Interactions layer.

• If you are adding learning interactions to a Macromedia Flash document you created, you can 
place stand-alone learning interactions on the Timeline in a single frame, sequential frames (for 
example, 10 questions in 10 sequential frames), or labeled frames. 

To add a learning interaction to the Timeline:

1 Do one of the following: 

• If you are using a quiz template, select the keyframe in the Interactions layer that contains the 
question preceding the interaction you are about to insert, and choose Insert > Blank 
Keyframe. Macromedia Flash inserts a blank keyframe after the keyframe you selected.

• If you are adding interactions to a document you created, select the appropriate layer, then 
choose Insert > Blank Keyframe. 

2 Do one of the following:
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• To add another interaction to the quiz template, open the document library (Window > 
Library) and open the 2_Learning Interactions folder.

• To add a stand-alone learning interaction, choose Window > Common Libraries > Learning 
Interactions. The Library – Learning Interactions panel appears.

There are six types of learning interactions in the library: True or False, Multiple Choice, Fill in 
the Blank, Drag and Drop, Hot Spot, and Hot Object. In addition, there are folders for Assets, 
GlobalClass, and Components. These are used for customizing learning interactions. See 
“Changing push buttons, check boxes, and radio buttons” on page 32.
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3 Select the new keyframe you created, then drag one of the Learning Interaction components 
from the Library panel to the Stage.

4 Reposition the interaction by dragging it to where you want it to appear on the Stage.

5 Configure the learning interaction. See “Configuring a learning interaction” on page 6.

Removing a learning interaction from the Timeline

When you remove a learning interaction from the Timeline, be sure to maintain the sequence of 
learning interactions. If you remove a frame from the Interactions layer, be sure to remove it from 
all other layers as well.

To remove an interaction from the Timeline

1 In the Interactions layer, select the keyframe containing the interaction to be deleted.

2 Press Delete or Backspace.

You can add another interaction to this keyframe or remove the keyframe from the Timeline 
(Insert > Remove Frames).

Note: Be careful to watch the frame count across layers as you are adding and removing keyframes. Make sure 
that all layers end at the same frame number along the Timeline so the frame count is the same in all layers. 

Testing to see if a movie clip is broken apart

Moving the movie clip containers around is easy once you know what you’re looking at. It is 
recommended that you check whether a learning interaction is broken apart or is still grouped 
within the container.

To verify whether a learning interaction is broken apart:

Select a text field or any single element of the learning interaction on the Stage.

• If a large grouped object is selected, the interaction is not broken apart.

• If you can select a single text field or another element, then the interaction has been broken 
apart and you can proceed with editing.

Note: Be careful not to break apart the Learning Interaction component. (You should be able to select it and see its 
parameters in the Component Parameter panel.) If the Learning Interaction component is broken apart, the 
interaction scripts will be lost. If this happens, delete the interaction and replace it with a new copy from the library.

Changing the appearance of a quiz

You can change the appearance of a quiz by modifying the title, the background, and other assets, 
such as text fields. You can modify properties such as font, size, and color. For more information, 
see “Changing the appearance of a learning interaction” on page 31.

To change the title of a quiz:

1 On the Stage, double-click the title text that says Practice Quiz.

2 Type the title for the quiz.

You can also change the contents of the background layer of the quiz without altering the way the 
quiz works.
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Testing the quiz

It is important to test a quiz frequently as you add and remove interactions.

To test the quiz:

1 Choose Control > Test Movie.

The quiz appears in the Macromedia Flash Player window.

2 Answer the questions as they appear. 

3 When you complete the quiz, close it in the Macromedia Flash player window to return to the 
work area in which you edit the document.

Configuring a Drag and Drop Interaction

You can use up to eight Drag objects and eight Target objects in each Drag and Drop interaction. 
Each Drag object can snap to any target named in the Drag and Drop component for evaluation. 
Drag objects can also share targets; for example, both Drag 1and Drag 2 can match Target 8. You 
can also specify a target without matching a Drag object to it. This allows you to add incorrect 
target distractors for evaluation.

Each Target object and Drag object is referred to as a distractor. A distractor is simply one of a 
series of selectable choices. This term is used for the choices in each of the learning interactions.

To configure a Drag and Drop interaction:

1 Place the learning interaction on the Stage, break it apart, display the Component Parameters 
panel, and then type the interaction ID and the question. See “Configuring a learning 
interaction” on page 6.

2 In the Drag Object Name column, list the instance names for the Drag objects on the Stage. 

Each Drag object must have a unique name. If you add a new Drag object on the Stage, be sure 
to enter its name here.

3 In the Matches Target Name column, list the matching target instance name for that 
Drag object. 

Each target must have a unique name. If you add a new target on the Stage, be sure to enter its 
name here.

If you enter a Drag instance name in the Drag Object Name column, you need to enter a 
corresponding Target instance name in the Matches Target Name column. However, you can 
enter a Target instance name in the Matches Target Name column without a matching Drag 
instance name. This adds a target that can be snapped to but will not be evaluated as a 
correct match.

4 Check the Snap to Start box to make the Drag objects snap back to their original position if 
they do not snap to a registered target.
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Adding and removing Drag and Drop objects and Target objects

You can change the default number of six objects and six targets by adding additional objects and 
targets, or by deleting existing objects and targets. You can include from one to eight Drag objects 
and one to eight Target objects in a Drag and Drop learning interaction. 

To add a Drag and Drop object or Target object:

1 Create a movie clip symbol containing the graphics for the object. For example, if you have an 
interaction that has six types of fruit, and you want to add a seventh choice, create a graphic of 
the seventh fruit and place it in the library.

2 Select the Drag and Drop learning interaction on the Timeline, then drag the symbol from the 
Library panel to the Stage. 

3 In the Property inspector, name the instance. See “Adding, naming, and registering assets” on 
page 22.

4 Add the instance name to the Component Parameters panel for the Drag and Drop object. See 
“Naming and registering graphic distractors” on page 24.

The component will do all the rest of the work for you at runtime.

To remove a Drag and Drop object:

1 Select the Drag and Drop instance that you wish to remove, and delete it from the Stage.

2 Select the component (the text to the left of the Drag and Drop interaction) on the Stage, then 
display the Component Parameters panel (Window > Components).

3 Remove the deleted object’s instance name from the appropriate column in the Component 
Parameters panel.

Note: If you register distractors for the Drag and Drop component that do not exist on the Stage, a Trace Output 
error message will appear when you test the movie.

Configuring a Fill in the Blank Interaction

The Fill in the Blank interaction uses a question text field, a user entry text field, a control button, 
and a feedback text field.

To set up a Fill in the Blank interaction:

1 Place the learning interaction on the Stage, break it apart, display the Component Parameters 
panel, and then type the interaction ID and the question. See “Configuring a learning 
interaction” on page 6.
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2 In the Component Parameters panel, enter one to three possible correct answers. 

You can set up the correct responses in one of the following ways:

• Type the text for the responses that the user can type that are considered correct responses. 
Select the Correct option to the right of the correct responses. 

• To set up the interaction to accept all responses except those you type, enter the invalid 
responses in the list and deselect the Correct option to the right of them. Then select the Other 
Responses option, to indicate that all other responses are correct.

3 Specify whether the matching responses are valid only if they match the case of the text you 
entered (by selecting Case Sensitive) or if they are valid regardless of the capitalization the user 
enters (by deselecting Case Sensitive).

4 Specify whether the matching response must be an exact match. If you select Exact Match, a 
correct response matches only if the user enters the text exactly as it appears in your response. 
With Exact Match deselected, an answer will be evaluated as correct if it contains the correct 
word. For example, if the answer is zebra and the user enters striped zebra, the answer will be 
considered correct. This feature does not work if the correct answer is more than one word.
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Configuring a Hot Object interaction

The Hot Object component accepts one to eight hot objects. The default sample uses six 
hot objects. 

To configure a Hot Object interaction:

1 Place the learning interaction on the Stage, break it apart, display the Component Parameters 
panel, and then type the interaction ID and the question. See “Configuring a learning 
interaction” on page 6.

2 For each object, select or deselect the Correct option to specify whether the object is considered 
a correct or incorrect response when the user clicks it. You can have multiple correct selections.

Adding and removing hot object choices

You can change the default number of six distractors by adding additional distractors or deleting 
existing distrators. You can include from one to eight hot object distractors (choices) in a Hot 
Object learning interaction. 

To add a hot object distractor:

1 Create a movie clip symbol containing the graphics for the hot object distractor. For example, 
if you have an interaction that has six types of fruit, and you want to add a seventh choice, 
create a graphic of the seventh fruit and place it in the library.

2 Select the Hot Object interaction on the Timeline, then drag the symbol from the Library 
panel to the Stage. 

3 In the Property inspector, name the instance. See “Naming and registering graphic distractors” 
on page 24.

4 Add the instance name to the Component Parameters panel for the hot object.

The component will do all the rest of the work for you at runtime.
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To remove a Hot Object distractor:

1 Select the Hot Object movie clip instance that you wish to remove, and delete it from the 
Stage.

2 Select the text to the left of the Hot Object interaction on the Stage, then display the 
Component Parameters panel (Window > Components).

3 Remove the deleted object’s instance name from the list in the Component Parameters panel.

Note: If you register distractors for the Hot Objects component that do not exist on the Stage, a Trace Output 
error message will appear when you test the movie.

Configuring a Hot Spot interaction

The hot spot learning interaction sets up an interaction in which the user responds correctly by 
clicking an object (or objects) onscreen. 

To configure a Hot Spot interaction:

1 Place the learning interaction on the Stage, break it apart, display the Component Parameters 
panel, and then type the interaction ID and the question. See “Configuring a learning 
interaction” on page 6.

2 For each hot area, select or deselect the Correct option to specify whether the object is 
considered a correct or incorrect response when the user clicks it. You can select multiple 
correct answers.

3 If needed, enter a value for Up State Alpha. This sets the default transparency of the hot spots 
on the Stage—that is, the transparency before you click on an area. To create completely 
invisible hot spots, leave this setting at 0.

4 If needed, enter a value for Down State Alpha. This sets the transparency of the hot spots when 
they are selected. This setting may vary depending on the graphics in your movie. You might 
want to use it to give users visual feedback after they have successfully clicked on a hot spot.
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Adding and removing Hot Spot distractors

You can include from one to eight distractors (choices) in a Hot Spot learning interaction. You 
can change the default number of six distractors by adding additional distractors or deleting 
existing distrators.

In general, you’ll be placing the Hot Spot distractors over another graphic that the user is really 
intended to see. You may want to make your Hot Spot assets semi-invisible during authoring to 
visualize this. You can do this by turning the alpha effect setting down on each hot spot. This 
setting is overridden by the interaction scripts at runtime.

To add a Hot Spot distractor:

1 Create a movie clip symbol containing the graphics for the distractor object. For example, if 
you have an interaction that has six types of cars, and you want to add a seventh choice, create 
a graphic of the seventh car and place it in the library.

2 Select the Hot Spot interaction on the Timeline, then drag the symbol from the Library panel 
to the Stage. 

3 In the Property inspector, name the instance. See “Naming and registering graphic distractors” 
on page 24.

4 Add the instance name to the Component Parameters panel for the hot spot.

The component will do all the rest of the work for you at runtime.

To remove a Hot Spot distractor:

1 Select the Hot Spot instance that you wish to remove, and delete it from the Stage.

2 Select the text to the left of the Hot Spot interaction on the Stage, then display the Component 
Parameters panel (Window > Components).

3 Remove the deleted object’s instance name from the list in the Component Parameters panel.

Note: If you register distractors for the Hot Objects component that do not exist on the Stage, a Trace Output 
error message will appear when you test the movie.

Configuring a Multiple Choice interaction

In a Multiple Choice interaction the user responds to a question with multiple answers in which 
one or several answers can be correct.
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To configure a Multiple Choice interaction:

1 Place the learning interaction on the Stage, break it apart, display the Component Parameters 
panel, and then type the interaction ID and the question. See “Configuring a learning 
interaction” on page 6.

2 Type the possible responses for the interaction (A–F).

Note: You do not need to provide six responses. You can leave some of the fields blank, but be sure to leave the 
final fields in the list blank. 

3 Select or deselect the Correct option to specify whether each response is considered correct or 
incorrect. You may have multiple correct answers.

Adding and removing Multiple Choice distractors

You can include from one to eight distractors (choices) in a Multiple Choice learning interaction. 
You can change the default number of six distractors by adding additional distractors or deleting 
existing distrators.

To add a Multiple Choice distractor:

1 Select the frame with the Multiple Choice learning interaction in the Timeline.

2 Open the Flash UI Components folder in the Library panel (Window > Library) and drag a 
CheckBox component to the Stage.

3 In the Property inspector, name the instance. See “Naming and registering graphic distractors” 
on page 24.

4 Add the instance name to the Component Parameters panel for the Multiple Choice distractor.

The component will do all the rest of the work for you at runtime.
16



To remove a Multiple Choice distractor:

1 Select the CheckBox instance that you wish to remove, and delete it from the Stage.

2 Select the text to the left of the Multiple Choice interaction on the Stage, then display the 
Component Parameters panel (Window > Components).

3 Remove the deleted object’s instance name from the list in the Component Parameters panel.

Note: If you register distractors for the Multiple Choice component that do not exist on the Stage, a Trace Output 
error message will appear when you test the movie.

Configuring a True or False interaction

In a True or False interaction the user responds with either a true or false response.

To configure a True or False interaction:

1 Place the learning interaction on the Stage, break it apart, display the Component Parameters 
panel, and then type the interaction ID and the question. See “Configuring a learning 
interaction” on page 6.

2 In the Question text box, type the text of the question you want to ask the user. 

3 Select Correct to specify which answer, True or False, is the correct response for the interaction. 
You can change these responses to Correct or Incorrect if you like by changing the text of the 
distractors. For example, you could type A. Correct and B. Incorrect in the Distractors field. 

About True or False interaction distractors

The True or False interaction includes a question text field, two RadioButton components, a 
control button, and a feedback text field. There are no other distractor options to configure. 

Setting feedback options for an interaction
Feedback options control what happens when a user selects a response.
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To set feedback options for an interaction:

1 Select the instructions for the interaction on the Stage.

2 If the Component Parameters panel is not already visible, choose Window > Component 
Parameters. Then click the Options tab.

3 Select Feedback if you want the movie to present comments to users immediately after they 
submit a response. 

4 If you selected Feedback, enter the following:

• For Tries, enter the number of tries that a user will have to provide a correct response.

• For Initial Feedback, enter the feedback that appears before the user has interacted with the 
movie—for example, Click an object and drag it to the matching object.

• For Correct Feedback, enter the feedback that appears if the user’s response is correct—for 
example, Yes, that is correct. 

• For Incorrect Feedback, enter the feedback that appears if the user’s response is incorrect and 
tries is set to 1—for example, No, that is incorrect.

• For Additional Tries, enter the feedback that appears if the user’s response is incorrect and tries 
is set to more than 1—for example, No, that is incorrect. Try again. 

Note: Users are allowed only one try for the True or False learning interaction, so there is no Additional Tries field 
for that interaction.
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Setting Knowledge Track options for an interaction
Knowledge Track works with both AICC- and SCORM-compliant LMS. It is an automatic data-
tracking feature that allows you to transmit student performance data to an LMS-like Lotus 
LearningSpace, or to other back-end tracking systems. Knowledge Track captures and/or stores 
student information internal to the Macromedia Flash movie and transmits that data to an 
HTML page. 

To successfully send data to a tracking system, you must embed the Macromedia Flash movie 
containing your learning interactions into an HTML page that includes the appropriate 
JavaScript. This is generated when you publish the movie and select the publish settings for either 
Flash w/AIC Tracking or Flash w/SCORM Tracking. To support AICC-compliant LMS, the 
HTML that embeds the HTML movie needs to be part of a frameset. See “Preparing movies for 
web hosting” on page 34.

The tracking data captured and transmitted by Knowledge Track is based on an industry standard 
for courseware-to-tracking-system communications, the AICC (Aviation Industry CBT 
Committee) specification version 2.0. This standard specifies the following data elements for each 
interaction.

You can set values for these data elements using the Component Parameters panel for an 
interaction:

• InteractionID

• ObjectiveID

• Weighting

Other data elements are automatically set or calculated:

• Question Type

• Correct Response

• User Response

• Result 

• Date/Time 

• Latency
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To set Knowledge Track options for an interaction:

1 Select the instructions for the interaction on the Stage.

2 If the Component Parameters panel is not already visible, choose Window > Component 
Parameters. Then click the Options tab.

3 Select Knowledge Track if you are using the learning interaction in a document created using 
a Quiz template and you want the movie to send data to a server-side learning management 
database. 

4 Enter a name in the Objective ID text box to specify an objective for the interaction.

This is an optional parameter. If the interaction is related to an objective that is set up in the 
LMS, enter that Objective ID in this text box. Tracking still works if you leave the Objective 
ID text box blank.

5 Specify the Weighting value for the interaction. The quiz templates use this parameter to 
calculate the score in the Results page. The default value is 1. 

Weighting indicates the relative importance of a question. You can enter any numeric value. If 
all learning interactions have a weight of 1, they are all scored equally. A weight of 2 counts 
twice as much as a weight of 1 and half as much as a weight of 4. For example, you can give 
advanced questions a weight of 3 and beginning-level questions a weight of 1. 
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Setting navigation options for an interaction
Documents created using the quiz templates have built-in navigation, so be sure to set Navigation 
to Off for learning interactions you use in these documents. 

To set navigation options for an interaction:

1 Select the instructions for the interaction on the Stage.

2 If the Component Parameters panel is not already visible, choose Window > Component 
Parameters. Then click the Options tab.

3 Under Navigation, specify how the movie will proceed after the user submits a response for this 
interaction:

• Click Off to disable navigation.

• Click Next Button to require the user to press the Next button after submitting a response, 
then in the Go To Action field, select either Stop or Play. 

If you want to navigate to a labeled frame instead of the next frame, in the GoTo Label field 
enter a frame label. 

The default text for the Next button is Next Question. If you want to change the text, see 
“Changing the text for the Next button” on page 38.

• Click Auto GoTo Next Frame to have the movie proceed to the next frame after the user 
submits a response.

If Feedback is deselected and Knowledge Track is selected, the Auto GoTo Next Frame feature 
can be enabled. This feature submits a score after evaluation and immediately navigates to the 
next frame for the next interaction. 

Note: If Feedback is selected or Knowledge Track is deselected, Auto GoTo Next Frame will be reset to Next 
Button and an error message will appear in the Output window. 
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Adding, naming, and registering assets
Each Macromedia Flash MX learning interaction consists of the following assets:

• An interaction component

• Dynamic text fields

• Distractor elements

• PushButton user interface (UI) component

The collection of assets for each interaction type is stored within movie clip symbols in the library. 
These movie clips are intended to provide mobility for the assets so they can be copied to 
keyframes or among files. They are only intended to be containers and are not necessary to make 
the interaction work. 

If you are a developer with experience handling and naming graphics, you can enter your own 
instance names for the graphic assets on the Stage. You do not need to use the movie clip 
containers or the templates—instead, you may add your own assets to the Stage, add a Learning 
Interaction component to the Stage, then register the assets’ instance names in the Component 
Parameters panel for the interaction.

Keep in mind the following about naming assets:

• Interaction components do not need to be named.

• UI components need to have unique names for similar interaction types.

• Each graphic distractor (Drag objects, Target objects, hot spots, and hot objects) must have a 
unique instance name.

• Text fields can share the same instance names across multiple interactions.

Once the assets on the Stage are named, it’s important to register those names in the Component 
Parameters panel for the learning interaction so that the scripts can control the assets. 

Naming Learning Interaction component instances

Every interaction has an interaction component associated with it to configure its unique 
parameters. These components do not need to be named.

Naming UI components (RadioButtons, CheckBoxes, and PushButtons) 

When you use similar interaction types, you need to give each UI component a unique name. For 
example, if you create two Multiple Choice interactions, the second interaction requires unique 
instance names for the CheckBox and the PushButton components. These new instance names 
need to be registered with the interaction component parameters.

To name a UI component: 

1 Select the UI component instance on the Stage.

2 In the Property inspector, click the Parameters tab, then type a name in the Instance Name text 
box.

3 Register the name. See “Registering dynamic text fields and PushButton components” on page 23.
22



Naming dynamic text fields

If you have more than one of any type of learning interaction in a quiz—for example, if you have 
two Drag and Drop learning interactions—the objects in each learning interaction must have 
unique names. These new unique instance names need to be registered with the interaction 
component parameters. See “Registering dynamic text fields and PushButton components” on 
page 23.

To name a dynamic text field:

1 Select the dynamic text field on the Stage. 

2 In the Property inspector, click the Parameters tab, then type a name in the Instance Name 
text box..

Note: Make sure to enter the Instance name and not the Variable name in the Property inspector.

3 Register the names.

Registering dynamic text fields and PushButton components

After you have entered the instance name in the Property inspector, you need to register it in the 
Component Parameters panel for the interaction.

To register dynamic text fields and PushButton components:

1 Select the text to the left of the learning interaction on the Stage and display the Component 
Parameters panel (Window > Components).

2 Click the Assets button.

Instance name
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3 Enter the name in the appropriate instance name text box.

Naming and registering graphic distractors

Graphic distractors such as Drag objects, Target objects, hot spots, and hot objects need to be 
named uniquely across all interactions. This means that in a file with two Drag and Drop 
interactions, each containing four Drag objects, each of the eight Drag objects must be named 
uniquely. For example, the Drag objects in the first interaction could be named Drag 1, Drag 2, 
Drag 3, and Drag 4, and the Drag objects in the second interaction could be named Drag A, Drag 
B, Drag C, and Drag D. This ensures that the scripts work properly and the interactions behave 
as intended.

To name graphic distractors:

1 Make sure that the objects on the Stage are instances of learning interactions or movie clip 
symbols. 

2 Select an object on the Stage—for example, a Target object.

3 In the Property inspector, click the Parameters tab, then type a name in the Instance Name 
text box.

4 Repeat steps 1 through 3 for each object on the Stage.

5 Register the names. 

Note: A sequential naming scheme is usually the easiest to work with—for example Drag1, Drag2, Drag3.

To register a distractor instance name:

1 Select the component (this is, the text to the left of the learning interaction) on the Stage and 
display the Component Parameters panel (Window > Components).
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2 Enter the name in the Instance Name text field on the Interaction tab in the Component 
Parameters panel.

Text field names

Text fields can share the same names from interaction to interaction. That means that the 
question text field in interaction 1 can be named the same as the question text field in 
interaction 2, and so on. These names need to be registered with the interaction components, 
as do all assets names.

Asset name defaults

The assets supplied in the movie clip interaction containers are prenamed with the instance names 
listed in the following tables.
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Drag and Drop learning interaction asset names 

Fill in the Blank learning interaction asset names

Hot Object learning interaction asset names

Hot Spot learning interaction asset names

Asset Description Object type Instance name

Question text field Holds question text Dynamic text field Template_Question

Feedback text field Holds feedback text Dynamic text field Template_Feedback

Control button Submits user response and 
controls navigation

Flash UI PushButton 
component

Template_ControlButton

Reset button Resets drag objects Flash UI PushButton 
component

Template_ResetButton

1-8 Drag objects Drag object distractors Movie clip symbol Drag1 – Drag8

1-8 Target objects Targets for Drag objects Movie clip symbol Target1 – Target8

Asset Description Object type Instance name

Question text field Holds question text Dynamic text field Template_Question

Feedback text field Holds feedback text Dynamic text field Template_Feedback

User entry field User types answer into 
this text field

Input text field Template_UserEntry

Control button Submits user response 
and controls navigation

Flash UI PushButton 
component

Template_ControlButton

Asset Description Object type Instance name

Question text field Holds question text Dynamic text field Template_Question

Feedback text field Holds feedback text Dynamic text field Template_Feedback

Control button Submits user response and 
controls navigation

Flash UI PushButton 
component

Template_ControlButton

Reset button Resets Hot Object 
distractors

Flash UI PushButton 
component

Template_ResetButton

1-8 hot objects Hot Object distractors Movie clip symbol HotObject1 - 8

Asset Description Object type Instance name

Question text field Holds question text Dynamic text field Template_Question

Feedback text field Holds feedback text Dynamic text field Template_Feedback

Control button Submits user response and 
controls navigation

Flash UI PushButton 
component

Template_ControlButton

Reset button Resets Hot Object 
distractors

Flash UI PushButton 
component

Template_ResetButton

1-8 hot spots Hot Spot distractors Movie clip symbol HotSpot1 - 8
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Multiple Choice learning interaction asset names

True or False learning interaction asset names

Modifying the design of a learning interaction
You may want to modify the visual design of a learning interaction so that it fits your needs, 
particularly if the interaction is more graphics-based than text-based, as are Drag and Drop, Hot 
Spot, and Hot Object interactions. For example, the default graphics for a Drag and Drop 
interaction are intended to be replaced with graphics that suit your needs.

Modifying the graphic design involves four procedures (described in the following sections):

• Managing assets

• Creating copies of interactions in the Library panel

• Changing graphics

• Customizing Macromedia Flash components

Asset Description Object type Instance name

Question text field Holds question text Dynamic text field Template_Question

Feedback text field Holds feedback text Dynamic text field Template_Feedback

Control button Submits user response and 
controls navigation

Flash UI PushButton 
component

Template_ControlButton

3-8 check boxes Check box distractors Flash UI CheckBox 
component

Checkbox1-8

Asset Description Object Type Instance Name

Question text field Holds question text Dynamic text field Template_Question

Feedback text field Holds feedback text Dynamic text field Template_Feedback

Control button Submits user response and 
controls navigation

Flash UI PushButton 
component

Template_ControlButton

2 radio buttons True or False Radio Button 
distractors

Flash UI RadioButton 
component

Template_Radio1,
Template_Radio2
Using Macromedia Flash MX learning interactions 27



Managing assets

When you drag a learning interaction from the learning interactions common library to the Stage, 
the symbols used by that learning interaction are copied from the common library to the library 
of the Macromedia Flash document you are creating. For example, if you copy a Drag and Drop 
learning interaction from the learning interactions common library to your document, the 
following symbols are added to the document library (in addition to any other symbols already in 
the document).

These symbols correspond to the symbols in the learning interactions common library. They are 
copied from the common library into your document so that if you make changes to them, the 
originals (in the common library) are not affected.

However, symbols in the document library are not arranged in the same way that they are in the 
learning interactions common library. In the learning interactions common library, the symbols 
used by the main learning interaction document are arranged in an Assets folder. For example, in 
the case of the Drag and Drop interaction, the learning interactions common library contains a 
DragAndDrop component and a DragAndDrop Assets folder.
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To better manage the symbols in your document, you can arrange them in subfolders in the 
Library panel. It’s a good idea to do this if you use many learning interactions or if you will use 
the same type of interaction more than once with a modified graphical design.

To move the learning interaction symbols to a folder in the Library panel:

1 If the library for the document is not already visible, choose Window > Library.

2 Click the New Folder icon at the bottom of the Library panel:

A new untitled folder is created in the Library panel.

3 Type a name for the new folder, such as Drag and Drop or Hot spot 1.

Your name might correspond to the type of interaction, such as Multiple Choice, or to its use 
in the document, such as Question 5.

4 In the Library panel, drag the symbols for the learning interaction you are working with into 
the new folder. 

Shift-click or Control-click (or Command-click on the Macintosh) to select multiple items in 
the Library panel.

Be careful not to select any of the assets that do not belong to the learning interaction.

Creating copies of interactions in the library

Whenever you change the graphical appearance of a symbol in the library, all instances of the 
symbol in the document also change.

For this reason, if you intend to use a specific type of learning interaction more than once in a 
Macromedia Flash document, and you wish to use a different graphical design for each copy (or 
instance) of the learning interaction, you need to make copies of the symbol in the library for 
each copy of the interaction. 

For example, if your quiz will have two Hot Object interactions based on the Hot Object 
component in the learning interactions common library, and they use different graphics as their 
hot object targets, you will need to have two copies of the Hot Object symbol in the library.
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To create copies of a learning interaction in the Library panel:

1 If you have not already done so, drag the first copy of the interaction from the learning 
interactions common library to your document, and move the related symbols into a folder 
within the Library panel, as described in “Managing assets” on page 28.

2 In the document Library panel, rename the copied symbols.

For example, in the case of a Hot Object learning interaction, the document library contains 
these symbols:

• Hot_Object1

• Hot_Object2

• Hot_Object3

• Hot_Object4

• Hot_Object5
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• Hot_Object6

You may choose to rename these symbols as follows:

• 01_HotObject

• 02_HotObject

• 03_HotObject

• 04_HotObject

• 05_HotObject

• 06_HotObject 

3 Drag a new copy of the learning interaction from the learning interactions common library to 
the document.

You can now adjust the graphics in each of the copies of the learning interaction without 
affecting the appearance of the other copies.

Changing the appearance of a learning interaction
Once a learning interaction has been added to the Stage and broken apart, you can place and size 
the assets. For example, you can extend text fields so they can accommodate more lines of text, 
and you can adjust the font, size, color, and other properties. You can add graphic elements to the 
learning interaction as well.

Changing the graphics in a learning interaction

For Drag and Drop, Hot Spot, and Hot Object learning interactions, you can change the 
appearance of the graphic distractors in the interaction to suit the purposes of your course. Keep 
in mind that whenever you change the appearance of a library item, its appearance changes 
throughout the document. (See “Managing assets” on page 28 and “Creating copies of 
interactions in the library” on page 29.)

The graphics for navigation buttons and for True or False and Multiple Choice interactions are 
created using UI components. Changing these graphics is recommended only for intermediate 
and advanced users. For more information, see Flash MX Help > Using Flash > Using 
Components. You can also resize and slightly modify the appearance of these graphics. See 
“Changing push buttons, check boxes, and radio buttons” on page 32.
Using Macromedia Flash MX learning interactions 31



To change the appearance of a Drag and Drop object, hot spot, or hot object:

1 In the Timeline, select the keyframe that contains the movie clip.

2 On the Stage, double-click the part of the learning interaction that you want to edit. 

Macromedia Flash updates the title at the bottom of the Timeline to show which symbol 
you are editing. 

3 Use Macromedia Flash tools and commands to edit the symbol on the Stage as you’d like it to 
appear in your document.

4 When you’ve finished editing the symbol, choose Edit > Edit Document.

Changing push buttons, check boxes, and radio buttons

The learning interactions use the Macromedia Flash MX user interface (UI) PushButton, 
CheckBox, and RadioButton components. You must use these UI components within the 
learning interaction templates. The learning interaction scripts use the internal features of the UI 
components to make everything work correctly.

The quiz templates already contain all the necessary UI components for each interaction.

Sizing

The PushButton components used for the Control button and Reset button can be scaled to fit 
your needs, The CheckBox and RadioButton component graphics can’t be scaled in height; 
however, you can scale these components horizontally to extend the viewable horizontal text area.

Changing the UI component graphics

There is a defined process for changing the skin of a component. For more information, see 
Macromedia Flash MX Help > Using Flash > Using Components.

Adjusting the UI component text

You can use the GlobalStyleSheet object to change the text characteristics of a UI component. 
This is described in detail in Macromedia Flash MX online help (Help > Using Flash > Using 
Components). 
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Using components within the learning interaction templates

To use components with the learning interaction templates, you simply add the correct UI 
components to the interaction assets and name their instances. You then need to register the 
instance names with the interaction component associated with that interaction. Each interaction 
template already contains the appropriate UI components as named instances. See “Adding, 
naming, and registering assets” on page 22.

Complete documentation on the UI components can be found in the Macromedia Flash MX 
online help (Help > Using Flash > Using Components). 

Note: UI components have component parameters associated with them. The learning interaction scripts override 
the UI component parameters at runtime. There is no need to fill out individual parameters for each PushButton, 
CheckBox, or RadioButton component.

Tracking to AICC- or SCORM-compliant learning management 
systems (LMS)

The Flash learning interactions and quiz templates easily allow communication with both AICC- 
and SCORM-compliant LMS. The code built into both the Flash documents and the 
corresponding HTML/JavaScript files send properly formatted data to the LMS. The stand-alone 
interactions send question data, while the quiz templates track the score and time spent overall. 

Because of differences between the two different tracking standards (AICC and SCORM), there 
are differences in the compliance of the files created using the Flash MX learning interactions and 
quiz templates. 

To be SCORM-compliant, content must call an Initialize command when it is first launched, or 
before any other tracking commands are sent to the LMS. Only the quiz templates send an 
Initialize command; the stand-alone interactions do not. Therefore, the interactions might not 
work and won’t be compliant independent of the quiz template, unless the interactions are added 
to Flash content that does initialize the LMS communication. 

The files created using both the Flash MX learning interactions and quiz templates can send 
tracking data to an AICC-compliant LMS. Individual interactions can not send overall score and 
tracking data, but they can send interaction or question data. 

In addition, quizzes created to comply with either AICC or SCORM standards will not read data 
from the LMS into the Flash file.

Overview of the communication for AICC- and SCORM-compliant content

The following provides a brief overview of what a student experiences when completing a quiz, 
along with hidden steps that are not exposed to the student. 

AICC communication overview

When a student takes an AICC-compliant quiz, the following events occur:

1 The LMS is launched.

2 The student logs in to the LMS.

3 The student navigates through the course structure to find an assignable unit (AU). In this 
case, assume it’s a Flash quiz, built using a Flash MX quiz template.

4 The student launches the Flash content (the quiz).
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5 The content is located on a web server, for example, http://myserver/flashcontent.htm. To 
track properly, the Flash file needs to be embedded in the Flash/AICC tracking frameset. See 
“Preparing AICC-compliant files” on page 34.

Note: This is not exposed to the user.

6 The LMS creates two parameters that are appended to the end of the URL: AICC_URL and 
AICC_SID. The final URL when the content is launched looks something like the following:

http://myserver/flashcontent.htm?AICC_URL=http://mylmsserver/
trackingurl.asp&AICC_SID=12345 

Note: This is not exposed to the user.

7 The student progresses through the quiz.

8 The Flash movie sends the tracking data to the LMS through the HTML/JavaScript tracking 
files. The tracking data is sent when the student answers a question and/or progresses to the 
next page. 

Note: This is not exposed to the user.

SCORM communication overview

When a student takes an SCORM-compliant quiz, the following events occur:

1 The LMS is launched.

2 The student logs in to the LMS.

3 The student launches a quiz built using a Flash MX quiz template.

4 The content is embedded in the Flash/SCORM HTML template, which is launched in a 
SCORM-compliant frameset. 

Note: This is not exposed to the user.

The LMS is responsible for creating the SCORM-compliant frameset, which includes all the 
necessary functions to communicate back to the LMS. 

5 The student progresses through the quiz.

6 The Flash file sends the tracking data to the LMS through the HTML/JavaScript tracking files. 

Preparing movies for web hosting

In order for web users to be able to see your Macromedia Flash movie, you need to embed it into 
a web page.

The steps to prepare AICC- and SCORM-compliant files for web hosting are slightly different.

Preparing AICC-compliant files

To send tracking data to an AICC-compliant LMS, you need to enable tracking for the quiz and 
then publish the movie using the Flash w/AICC Tracking template. You must place the HTML 
and SWF files generated by Macromedia Flash on your web server in the same directory and 
modify the frameset file with the name of your quiz, then place it on the web server with the 
HTML and SWF files. In addition, your LMS must be AICC-compliant and reference the 
frameset. By default, this is the file called frameset.html.
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To prepare an AICC-compliant file for web hosting:

1 Open the document in Flash MX.

2 Choose File > Publish Settings.

3 In the Publish Settings dialog box that appears, make sure that both Flash (.swf ) and HTML 
are selected in the Formats panel.

4 Click the HTML tab at the top of the Publish Settings dialog box and select the Flash w/AICC 
Tracking template.

5 Click the Publish button and close the dialog box.

6 Place the Flash SWF file and the HTML file produced by publishing the Flash file on the web 
server, both in the same directory.

7 Open the Learning Extensions Srvr Files subfolder, located in the Flash MX program folder 
First Run\HTML\Learning Extensions subfolder. Copy the contents of this folder 
(frameset.htm, results.htm, and the scripts subfolder) to the same web server directory as the 
SWF file and the HTML file published in Flash.

8 Open the new copy of the frameset.htm file in a text editor.

The following lines are found in the frameset.htm file:

<frameset frameborder="0" border="0" framespacing="0" rows="*,1">  
<frame src="Untitled-1.htm" name="content" frameborder="0">
<frame src="results.htm" name="cmiresults" scrolling="0" frameborder="0">

9 In the second line, change Untitled-1.htm to the name of the HTML file you published in 
Flash.

10 Launch the LMS system (or create the AICC Course Descriptor Files) that references the 
frameset.htm file.

Preparing a SCORM-compliant movie

To send tracking data to an SCORM-compliant LMS, you must enable tracking for the quiz and 
publish the movie using the Flash w/SCORM Tracking template. In addition, you need to place 
the HTML and SWF files generated by Macromedia Flash on your web server in the same 
directory.

To prepare a SCORM-compliant movie for web hosting:

1 Open the document in Flash MX.

2 Choose File > Publish Settings.

3 In the Publish Settings dialog that appears, make sure that both Flash (.swf ) and HTML are 
selected in the Formats panel.

4 Click the HTML tab at the top of the Publish Settings dialog box and select the Flash w/
SCORM Tracking template.

5 Click the Publish button and close the dialog box.

6 Place the Flash SWF file and the HTML file produced by publishing the Flash file on the web 
server, both in the same directory.

7 Launch the LMS system and reference the name of the HTML file. Make sure the LMS is set 
to launch the SCORM tracking frameset. 
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Extending learning interaction scripts

Note: The information in this section is intended for intermediate and advanced developers who want to extend the 
interaction capabilities. 

The Macromedia Flash learning interactions use a very organized data structure to store and 
retrieve information about each interaction session. This powers the evaluations and opens up 
new possibilities for developers wishing to extend tracking features. Just tap in, and pull out 
industry-compliant tracking data. This data structure is called the SessionArray.

Note: SessionArray and session are reserved keywords on the level where the interactions lie. Do not use these 
words as identifiers for other data.

Accessing cumulative tracking data through the SessionArray

The following is an overview of how data is tracked through the SessionArray.

• When the Flash movie is launched, the first interaction component to load creates a new Array 
on the level of the interaction assets. 

• The component then creates a new instance of the LToolBox global class in index0 of the 
Array. The instance of LToolBox is a storage place for all of the interaction’s data. Data is set or 
retrieved from the instance by using predefined property names. See “Predefined property 
names” on page 37.

• When the Timeline moves to the second interaction, that interaction’s component creates an 
instance of LToolBox global class in index1 of the SessionArray. 

• When the Timeline moves to the third interaction, that interaction’s component creates an 
instance of LToolBox global class in index2 of the SessionArray. It continues with index3, 
index4, and so on, until all interactions are in an index.

• At the end of a series of interactions, all the data processed during those interactions are 
available and organized.

Note: The SessionArray is used the same way in the stand-alone interactions and the quiz interactions.

Possible uses 

This information is most useful to developers who need to extend tracking or analysis of the 
interactions, including creating customized quiz environments and creating quizzes in a format 
different from that of the Macromedia Flash quiz templates.

Tracking properties available in the SessionArray

The property names references standard interaction tracking values for both AICC and SCORM 
LMS. You can retrieve an interaction’s properties by referencing its location in the following 
command:

SessionArray[n].[property_name]

For example, to reference the interaction_ID value for interaction #1, you would use this 
command:

SessionArray[0].interaction_ID

To reference the result value for interaction #2, you would use this command:

SessionArray[1].result
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Predefined property names

The following table describes the predefined property names.

All the methods and properties of the LToolBox global class are available within each 
SessionArray index.

Basic structure of the Learning Interaction scripts and components

Now that you know how the interaction data are stored and retrieved, here’s a little more 
information to round out the picture. The Learning Interaction components are really the heart 
of the whole setup. They collect user parameters and build the SessionArray and the interaction 
event handling functions on the level of the interaction assets. That is, they accept user 
parameters and configure the environment and assets accordingly. If you want to examine how 
these work, you’ll need to open the scripts in the Library panel.

The majority of the scripts lie in one of two places. The first is the LToolBox global class, 
which we’ve already mentioned. This script processes data storage and data formatting for the 
interaction. The second script location is within each interaction component. These scripts 
initialize event handling functions triggered by the interaction assets. This is where the user 
parameters and interaction assets are initialized and the interaction evaluations scripts lie. Even 
though these scripts are built on the component level, they are initialized on the same level as the 
interaction assets and submit data to the SessionArray on the interaction assets level.

If you want to explore the scripts or add to them, look in the library for the LToolBox global Class 
and the Components folder for each Learning Interaction component script. Each script is split 
into commented sections that are described at the top of the script. Most of the script sections are 
built within functions for modularity.

Property name Description

interaction_ID Unique interaction name

interaction_type Type of interaction

objective_ID Objective identification number

weighting Weighting value for this interaction instance. Some interactions can have more weight 
than others.

correct_response Formatted correct response returned from the user parameters

student_response Formatted student response returned from the evaluation

result Result of the evaluation

latency Elapsed time during this interaction session

dateStamp Date when the interaction occurs

timeStamp Time when the interaction starts
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Changing the text for the Next button

Changing the text for the Next button is an example of how you can modify the scripts.

The default text for the Next Button feature is Next Question. To change this to Next or any 
other text, you use ActionScript to change the text indicated for the LToolBox command. 

To change the text for the Next button:

1 Open the Library panel (Window > Library), then open the 1_LGlobalClass folder and open 
the LGlobalClasss movie clip.

2 Open the Actions panel (Window > Actions), and click the Find button. 

3 In the Find panel, type Next Question, then click Find Next. 
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4 Change the text to the text you want to be displayed for the button.

First occurrence of Next Question

5 In the Find panel, click Find Next to find the next occurrence of Next Question and change it. 
Changing these two occurrences changes every instance where the Next Question text occurs.
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